T O P

Logitech circle view camera is there a fix?

Logitech circle view camera is there a fix?

Jogameister

A fix? Yeah a trashcan. That’s where mine is at. Not worth the headache.


fartbox

HomeKit destroyed my circle cam. It used to be a good product with the Logitech app.


jorge1014

I returned mine...not really worth it yet...overheats and always disconnects...


seanhamsyd

Thanks - what replacement would you consider?


jorge1014

I honestly bought some eufy cameras from Costco...they came with the solar panels and I aim one at my front door...im thinking I'll wait until matter has been officially released so that I have more options


diannapalmer

My doorbell is doing this as of this week, and its incredibly frustrating! I have the logi doorbell, first went offline intermittently, and now has been off for three days…grrr!


Bikenanigans

Just got one of these and can’t connect to it at all. Thumbnail in home app shows fine, but just spins if I try to connect to it directly. Seems like HKSV doesn’t play nice with VPNs based on reading other posts. Shame since everything else I have works just fine. I really wanted a nice camera without third party service but I think I’m going to have to return this.


scorch968

Don’t have a connectivity issue usually. I do have a thermal shutdown that happens for a few weeks out of the year where the sun hits it straight on. It usually only shuts down for about 20 minutes. The doorbell is indeed hot. I feel like the first generation Nest doorbell solved this with a metal housing to dissipate the heat.


I_am_Zed

Logi is a pile of smoking garbage. Tech support offered 30% off msrp for a replacement. Never again.


robogobo

My Eufy doing the same thing. Typical HomeKit nonsense.


CaptainofClass

Mine used to do this. (Posted awhile back about it) I got a HomeKit smart outlet so I could power cycle it easily. What I didn’t expect was for that outlet to fix the issue. My camera hasn’t lost connection once since I’ve had it on the smart outlet. No clue why and Logitech couldn’t explain it either.


Redleader824

Thanks


Bastianoso

Same here, ironically


RobotCopPart9

Can you explain a bit further? Does the smart outlet power cycle on an interval, or when it loses connection? Or is the smart outlet somehow fixing the issue just by its mere presence? Also, which outlet? Just ordered a circle view and am now considering returning it due to all of the issues I’m reading about.


CaptainofClass

I have the Meross smart outlet. And no, it doesn’t power cycle automatically. It just fixed the issue. I have no idea why or how it just worked. Logitech tech support couldn’t explain it either. But it hasn’t lost connection once with the outlet plugged in.


bprendy

Yes… help is coming. Ask them (opens ticket with Logitech) for the early release of either 8.12.14 or 8.12.15. I had 12 disconnects a day, until I got the new firmware.


Redleader824

Nice… is there a difference between the two


bee144

Those firmware versions are really high, which lead me to believe he’s talking about the doorbell and not the standalone camera. Two different products with two different firmwares. OP, it’d help if you clarified what you’re using (doorbell or stand alone) because people are talking about both in this thread.


Redleader824

I see what your saying I’m talking about the standalone cameras


bee144

Is that for the doorbell or stand alone circle view?


bprendy

Doorbell , my stand-alone has been solid.


theronster

How do you upgrade the Doorbell firmware?


bprendy

You need to open a ticket with logitech. Once you follow all of their troubleshooting steps and are still having issues they should put you in the program.


Jamie00003

Buy something better. It seems every post in here is complaints about the Logitech doorbell


Foxyobrown19

Camera, not doorbell. My 3 ciecle view cameras work almost flawlessly


CleanestNdaC1ty

Did it overheat?


Redleader824

No heat, I have 3 and they all say this all day.closest is 10 ft from router,furthest around 25 ft away all inside


Im_A_Praetorian

Mine just started doing this 2-3 days ago with increasing frequency. It’s happening at night so I don’t think it’s heat, I think it’s just dying. It’s coming up on a year of being installed outside.


joshkinsey

There is a firmware in testing right now that fixed mine. I was having the same issue you are. Hopefully they push it out publicly soon. I had to contact support and go through their process and they pushed it to my device.


Im_A_Praetorian

Hopefully they are able to… right now my camera refuses to be seen in HomeKit, so I don’t know how it’s going to get the update since it’s a HomeKit only camera.


grrivera7

Thanks what is the new fw version number ?


Redleader824

I’ll look into it,this is the only thing keeping me from getting the doorbell I hear it’s the same issue


tlukes3

Same here, huge difference since running the new firmware


grrivera7

Fw version? Thx


grrivera7

Fw version? Thx


grrivera7

Fw version? Thx


grrivera7

Fw version? Thx


grrivera7

Fw version? Thx


grrivera7

Fw version? Thx


Jmco1

Have the same issue from time to time but power cycling the camera brings it back online.


pacoii

Doorbell or cameras?


Redleader824

Camera


pacoii

I’ve only had this happen once with mine, when my router lost power temporarily. A reboot of the camera fixed it. I hate to say it, but often the issue is with the wireless network.


Redleader824

Would could be the fix cameras in the same room wireless ax tri band router 1 gb service


anxcaptain

Happens to me… I restart my router and cam at the same time. I am going to try a static IP


makromark

Hey OP! I have had similar issues. First of all, is your router a HomeKit secure router? I noticed mine being enabled caused a whole bunch of issues, regardless of the setting for Logitech. Secondly, mine went away after just rebooting. I made a comment/post that mine would go offline until I unplugged. It’s been a few days and no issues. I’d just keep power cycling


Redleader824

No HomeKit router and rebooting helps but we shouldn’t have to do this every day or even every week


makromark

Yeah, someone else’s workaround was to get a HomeKit plug so they could easily reset. Which I thought was insane. Again, it’s fixed for me for now, it seems like a reset finally “stuck”


Redleader824

I’ll try that


morkjt

My camera does the same. Every 4-5 months it goes flaky, does this a lot then finally and suddenly loses wifi connection and will not reconnect. I have to wipe it, do a hard reset and it goes back to being 100% reliable.


Redleader824

You would think a software update could fix this


Ok_Philosopher1142

My ring cameras exposed via HomeBridge are also doing the same thing in the last few days!


rdcyul

Often enough this kind of outage resolves itself on its own in a few minutes. Unfortunately the last time I had a camera go offline it stayed that way for over a day, so I held its button for 10 seconds to reset it then re-added it to my home. NGL it was a pain but (1) thankfully I had the setup code saved in HomePass and (2) it’s been stable since. Good luck!


NegativeNumber_2022

I’m on my 3rd unit having to go through warranty replacement twice. The product is half baked at best


sose5000

Amcrest. No HKSV but works with HA and HomeKit.


bowb4zod

Move your router closer.


Redleader824

Cameras mounted above router


bowb4zod

Damn


Redleader824

Honestly I’ve given up 300$ wasted …I’ve never wasted so much time on a product to be let down and support is non existent for a issue everyone that has the camera is going through.


iJimbov

i change the charging block on mine with one from my old iphone the small charging block and so far it’s good. no issues here.


janthony6

Usually it will say if it overheated. Likely you are under powering it. You need a transformer at the max that it allows.


nichewidgets

not for the camera.. it comes with a logitech adapter.. this isn't a doorbell..